Install flexget, fix ioerror 2

 

Following these steps http://flexget.com/wiki/InstallWizard/Linux/Environment/FlexGet you might get an error.

IOError ‘/home/username/build/tmdb3/setup.py’

sudo pip install https://pypi.python.org/packages/source/t/tmdb3/tmdb30.7.1.tar.gz#md5=a3de16b84747ddec0e40c5a54cb17173 

then installation should work

sudo pip install flexget 

http://flexget.com/ticket/2782

Then you will get this error on Ubuntu 14.04

$ flexget -V
Traceback (most recent call last):
File “/usr/local/bin/flexget”, line 5, in
from pkg_resources import load_entry_point
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 2749, in
working_set = WorkingSet.buildmaster()
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 446, in buildmaster
return cls.buildfrom_requirements(requires)
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 459, in buildfrom_requirements
dists = ws.resolve(reqs, Environment())
File “/usr/lib/python2.7/dist-packages/pkg_resources.py”, line 632, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (python-dateutil 1.5 (/usr/lib/python2.7/dist-packages), Requirement.parse(‘python-dateutil>=2.1’))

http://discuss.flexget.com/t/error-after-installing-flexget/414/11

Then to fix you run 

apt-get remove python-dateutil

 pip install https://pypi.python.org/packages/source/p/python-dateutil/python-dateutil-2.3.tar.gz#md5=14dae5a51d11802cc1e8828c5f797358

flexget -V

Leave a Reply